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1. Introduction 
The purpose of the Universal Archiving Module (UAM) is to simplify the incorporation of 

records and their descriptions into the agency’s Electronic Records Management System 

(ERMS), converting them to a format that matches requirements, and forwarding those with 

an archival value to the public archive. 

 Glossary 

Archival creator – a legal or physical entity whose activities result in the creation and 

accumulation of records that form an archive. 

Archival format – a file format used for long-term preservation of digital files. In Estonia, 

the list of archival formats is available in the National Archives’ digital archival system 

strategy and archival guidelines. 

Archival structure – the hierarchical classification structure used to classify single records at 

archives. The classification levels at the National Archives of Estonia are: archive/fond > sub-

archive/sub-fond > function > series > sub-series. 

Archive – a comprehensive assemblage of records created or received in the course of the 

archival creator’s activities. 

DHX – Document exchange protocol (DHX) is a standardised technical and organisational 

solution, enabling institutions to exchange documents, based on a distributed or decentralised 

principle. 

ERMS classification code – Classification code used in the ERMS to identify description 

units and records. 

Metadata – data about the data. For example a computer file can be described by metadata 

elements like file name, size, format, etc. 

Migration – the process of converting computer files from an obsolete file format to a new 

file format to overcome software obsolescence . 

Project – the process of preparing a set of records and their metadata for delivery into the 

National Archives’ digital repository. 

Public archive – the National Archives of Estonia and its subdivisions. 

Record container – an XML container designed to transfer the record and its metadata into 

the National Archives’ digital repository. 

UAM – Universal Archiving Module 

UAM ID – unique reference code created within UAM. 

Validation – the process of checking data against certain criterion / set of rules. 

X-Road/X-tee – is a data exchange layer used in Estonia. 

2. General Instructions  

2.1 Form buttons 

Each input form has its own set of buttons. However, some buttons repeat across forms, with 

the same functionality (Save, Delete, Print, Mark).  

The Save and Print buttons are always active (if the form has been saved at least once), and 

can be clicked. Other buttons may be inactive in some circumstances, if the corresponding 

action is not allowed (for example, the archival creator cannot be deleted if it is the parent for 

at least one archival project). The circumstances for the inactivity of buttons are explained 

separately in each form’s description. 

 

Save (available on all forms) – saves the form. Mandatory fields (marked with an *) 

must be filled first. 
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Add archival creator (available on archival creator form) – opens a form to add an 

archival creator.  

Add project (available on archival creator form) – opens a form to add a project. The 

archival creator form must be saved first. Only one project can be open at a time. 

Copy project (available on project view) – used to copy a project. 

Print (available on all input forms) – used to print form data. The current form must 

be saved first. 

Delete (available on all input forms) – deletes the open object and its sub-objects. The 

form must be saved first. 

Add sub-fond (available on fond form) – opens a form to add a sub-fond. The fond 

form (or previous form) must be saved first. 

Add function – (available on fond form) – opens a form to add a function. The fond 

form must be saved first. 

          Select function – (available on fond form) – opens a form to add a function described    

           in the archival creator’s view.  

Add sub-function (available on function form) – opens a form to add a sub-function. 

The function form must be saved first. 

Add series (available on function form) – opens a form to add a series. The (sub-

)function must be saved first. 

Add sub-series (available on series form) – opens a form to add a sub-series. The 

series must be saved first. 

Add dossier (available on series form) – opens a form to add a dossier. The project 

must be approved and the (sub-)series must be saved. 

Create relationship (available on fond, function, series and dossier forms) – creates a 

relationship between a previously marked object and the selected object. Requires a creation 

purpose (the Description field). The selected object’s history will be updated with the 

provided description. 

Merge (available on fond, function, series and dossier forms) – the button is only 

active when another same level object is marked. It is possible to merge only objects that are 

in the same level or object and its sub-object. 

Add as child (available on fond, function, series and dossier forms) – the marked 

record will be moved and made a child of the selected record. 
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Mark (available on fond, function, series and dossier forms) – the selected object will 

be marked. 

 Upload new file (available on file form) – the button is only shown in the file form. An 

imported file that is not in an archival format can be replaced with a new file. 

Save computer file on media (available on file form) – the button is only shown in the 

file form. The file can be saved to a local drive. 

Cancel work on the form (available on all input forms) – asks the user to confirm, and 

if so, cancels unsaved changes to the form. 

 Open file – the button is shown when viewing the contents of the record container in 

the file form. The file can be opened. 

 

2.2 Adding a New Row 

There are two ways to add a new row: 

• Save the entire form (click Save) 

• Press Enter on your keyboard. 

 
 

If the mandatory fields have not been filled, the system will produce a warning and highlight 

the empty mandatory fields in red. 

 
 

Clicking Yes in the warning window will let you correct the data. Clicking on the red icon 

will display the details of the error. 

 

Clicking No in the warning window will erase the entire row (not just the part that was left 

empty). 

2.3 Deleting Data in the Form 

To delete rows in the form, click on the row you want to remove and press the Delete key on 

your keyboard. 

2.4 Sorting 

The data in the form can be sorted (within one block). To do this, click on the column header. 
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An arrow will appear in the header of the column that is used to sort the data. 

 

Right-click on the column header to see the various sorting options. 

 

 
 

• Sort Ascending – rows are sorted by column contents, a>z. 

• Sort Descending – rows are sorted by column contents, z>a. 

• Clear Sorting – the previously applied sorting is removed. 

• Group By This Column – the data is grouped by the contents of this column. 

• Group By Box – the data is grouped by the contents of multiple columns. 

• Column Chooser – used to move columns. 

• Best Fit – the column width will be adjusted based on the contents (to best fit the data 

on the screen). 

 

Sorting is only visual, and will not be carried over to a printout. 

2.5 Archival classification tree view options 

The following buttons are available above the classification tree: 

- Expand branches – clicking the icon will open active branches in the classification 

tree. 

- Expand all branches – clicking the icon will open all branches in the classification 

tree. 

 - Collapse branches – clicking the icon will collapse active branches in the 

classification tree. 

- Collapse all branches – clicking the icon will collapse all branches of the 

classification tree. 

 

 

Example of a classification tree modification options: 
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Clicking the Plus sign will open the classification tree and display the object’s sub-elements. 

 

Right-clicking on the name will open the context menu: 

• Delete – the objects marked in the menu (and their sub-objects) will be deleted. Please 

note: the system may not delete an object that is open, only objects selected in the 

menu. Please note: there is no way to delete files manually. 

• Mark – the selected objects will be marked. 

• Add as child – the marked record will be moved and made a child of the selected 

record. 

• Merge – only visible when a different object of the same type has been marked. Only 

objects of the same type or an object and its sub-object can be merged.  

• Create relationship – a relationship will be created between a previously marked 

object and the selected object. The provided description will be added to the selected 

object’s activity history. 

  

To select multiple objects from the classification tree, hold down Ctrl (to select individual 

objects) or Shift (to select a range of objects) while left-clicking. 

3. Working with the application 
Below you can see the general workflow. You must start your work with describing the 

archival creator before you can construct an archival structure. 

 

 

Describe the 

archival creator

Describe an 

archival project

Describe the 

archival structure 

metadata

Upload the 

archival material 

metadata

Get approval for 

the archival 

structure from the 

national archive

Validate your 

archival project

Send your archival 

project to the 

national archive

Validate your 

archival project

Correct errors

Correct errors

National archive can ask 

you to make some changes 

in your project

 
Drawing 1. General workflow. 

 

Sending your archival project to the national archive is the last step you can perform with this 

application. Official confirmation that the current project is successfully completed is given 

by using external communication tools. 

3.1 Describing the Archival Creator 

 

The archival creator can be described both manually, and by importing a description in the 

XML format from the National Archives. 
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3.1.1 Manual Description 

Open the File menu and select Add archival creator. The archival creator addition form will 

open. 

 

 
Drawing 2a. Archival creator description type selection.  

 

There are choices “Organisation”,  “Person” and “Collection”. Choosing one of the options 

changes only the names of description elements of an agency/archival creator. The next 

screenshot shows a form of choice “Organisation”. 
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Drawing 2b. Archival creator description form. 

 

Metadata elements are divided on separate tabs. 

 

The mandatory fields (marked with an *) must be filled. In addition, at least one official name 

form must be added. Enter the Title and select the Type from the dropdown menu. The 

system will populate the language selection and date range automatically (these can be 

changed later). 

 

The list of mandates (in the Mandates panel) is filled automatically if the functions and their 

mandates have been added to the archival project. The mandates can also be added to the form 

manually. 

 

The inactive buttons on the form are: 

• All except Save and Cancel if the archival creator has not been saved. 

• All except Save and Print if the archival project has been marked as approved. 

• Add sub-creator always if it’s the sub-archive creator form. 

• Delete if the record has a project or sub-creator associated with it. 

3.1.2 Adding an Archival Creator from an XML(ARH) File 

Open the File menu and select Add creator from XML. The browser will open the file 

selection window. 
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Drawing 3. Adding an archival creator from an XML file. 

 

Determine the location of the file to be imported, select the file, and click Open. If the XML 

is valid, then the general view of the archival creator will be populated with the data from the 

file, including all sub-creators. 

 

 
Drawing 4. Archival creator general view. 

 

3.1.3 Updating the Archival Creator and Sub-Creator Data 

Updating the archival creator data is only possible while the archival structure is unapproved 

(see Starting a new archival project). Once the archival structure has been approved, the form 

is locked and the data cannot be changed. 

 

To update the creator data, open the archival creator general view (left-side menu) and click 

on the archival creator’s name. The right-side window will display the archival creator form. 

3.2 Describing the Archival Project 

In the context of the UAM, a project is the transfer of deliverable records to the public 

archive. 

3.2.1 Starting a New Archival Project 

To create a new project, open the archival creator or sub-creator view and click Add project. 

The data entry form will open. 
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Drawing 5a. Project adding view 

 

Dates cannot be filled manually, they will be automatically populated by the system: 

• Creation date – the date when the project was created. 

• Modified – the date when the project was last modified. 

• Transfer date – the date of the project’s last transmission.  

• Transmission description – whether the document was transferred via the DHX or an 

XML file was created. 

 

The project status selection affects the UAM’s behavior in the future (the behavior differs 

between the LITE version and the standard version).  

The LITE version does not include the project status, and therefore does not include the 

limitations based on the project status. 

• Changing the archival creator data 

o The standard version allows changes to the archival creator data only while all 

of the creator’s projects are in Archival structure unapproved or Project 

transferred status. 

• Changing the archival structure. 

o The standard version can only change the archival structure when the project’s 

status is Archival structure unapproved. 

• Changing dossiers, including record management in dossiers 

o The standard version can add and merge dossiers, add imported records to 

dossiers and delete records from dossiers only when the project status is 

Archival structure waiting for approval or Archival structure approved. 

• Validation of mandatory fields for archival structure units corresponds to the standard 

version’s validation when the project status is Archival structure unapproved. 

o Fonds and sub-fonds: 

▪ Mandatory: Title 

▪ Optional: Scope and Content, System of Arrangement 

o Function and sub-function: 

▪ Mandatory: ID and Name 
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▪ Optional: mandate. However, if the mandate is present, its data fields 

must be filled. 

o Series and sub-series: 

▪ Mandatory: UAM ID and Title 

o Mandatory unit fields are subject to the same validation rules in both the LITE 

version and the standard version. Validation of mandatory fields does not 

depend on the project status. 

 

The inactive buttons on the form are: 

•  Open, Transfer, Print, Copy, Delete if the project has not been saved. 

3.2.2 Updating the Archival Project Data 

To update the archival project data, go to the archival creator general view (in the left-side 

menu) and click on the project name. The project form will open in the right-side window. 

 

3.2.3 Copying the Archival Project 

A new archival project can be initiated by copying the existing project. Open the archival 

creator view and click Copy project 

   

 

The project description form will open. Since this is a new project, the fields in the view must 

be filled with the required data. Once that is done, click Save. 

 

 

After the form has been saved, the archival creator’s general view will include an option for 

the newly copied project.  

 
Drawing 5b. Copied project 

 

All data down to the series level will be copied from the selected archival project to the new 

project. 

3.3 Describing the Archival Structure Metadata 

 

There are three ways to enter the archival structure metadata:  

• The user will create functions and series in the UAM manually, by entering the data in 

the corresponding views.  

• The user will import the series and functions from the agency’s document 

management system (see section 8, Loading series/function metadata into the UAM).  

• The user will import the archival structure from an XML file (see the section Creating 

an archival structure from XML). 
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3.3.1 Fond level description 

Open the project (the Open button in the archival creator project form), and in the archival 

structure general view, click on the fonds name. The metadata description form will open. 

To add a new sub-fonds, open the (sub-)fonds form and click Add sub-fonds. 

 

 

 
Drawing 6. Fonds metadata 

 

An approved archival structure requires that the fields Scope and Content and System of 

Arrangement be filled.  

 

The Actions table cannot be filled manually. The data will be inserted automatically when an 

object is merged, added as a child, or deleted. Example: if two functions are merged into one, 

the new function’s actions table will contain a new action: Function merged: 1.1.1 

Function_Name. 

 

The Related Material table can be filled manually, but some data will also be inserted 

automatically by the system: 

• The Related Object value cannot be selected manually.  

• The system will only insert data if a relationship is created between two objects (the 

Create Relationship button). The column Related object will be populated with the 

name of the related object. 

 

The inactive buttons on the form are: 

• All except Save and Cancel if a new sub-fonds is being added, and the view has not 

been saved. 

• All except Save, Mark, Print and Cancel if the archival project has been marked as 

approved. 

• Create relationship if no other object has been marked.  

• Merge if no object of the same type has been marked. 

• Add as child if no series/function has been marked. 
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3.3.2 Function level description 

To describe the metadata of an existing function, go to the archival structure’s general view 

and click on the function’s name. The metadata description form will open. 

To create a new function, open the (sub-)fonds form and click Add function. 

 

 
Drawing 7. Function metadata 

 

To save the data, at least the mandatory fields (marked with an *) must be filled. In addition, 

at least one mandate must be added. 

 

In case functions were described in the archival creators’s metadata then they can be added to 

the archival structure via the dropdown menu or the Select function icon. 

 

Mandates can be added to the mandates table in two ways: 1) using the dropdown menu to 

add mandates that were described at the archival creator level, and 2) entering a new mandate. 

If a new mandate is entered, it automatically appears at the archival creator level. Every 

mandate can only be added once (considering all mandate values).  

 

Related material can be added to the related material table manually, but some data will also 

be inserted by the system: 

• The Related object value cannot be selected manually.  

• The system will insert data if a relationship is created between two objects (the 

Create relationship button). The column Related object will be populated with the 

name of the related object. 

 

The Actions table cannot be filled manually. The data will be inserted automatically when an 

object is merged, added as a child, or deleted. Example: if two functions are merged into one, 
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the new function’s actions table will contain a new action: Function merged: 1.1.1 

Function_Name. 

 

The inactive buttons on the form are: 

• All except Save and Cancel if the function has not been saved. 

• All except Save, Mark, Print and Cancel if the archival project has been marked as 

approved. 

• Add function, always if this is a sub-function form. 

• Create relationship if no other object has been marked.  

• Merge if no object of the same type has been marked. 

• Add as child if no series/function has been marked. 

 

3.3.3 Series level description 

To change the metadata of an existing series, open the archival structure general view and 

click on the series name. 

To add a new series, open the (sub-)function form and select Add series. In both cases, the 

metadata description form will open. 

 

 
Drawing 8. Series metadata 

 

To save the data, at least the mandatory fields (marked with an *) must be filled.  

 

Related material can be added to the related material table manually, but some data will also 

be inserted by the system: 

• The Related object value cannot be selected manually.  

• The system will insert data if a relationship is created between two objects (the 

Create relationship button). The column Related object will be populated with the 

name of the related object. 

 

The Access restrictions table contains the mandatory fields Restriction notice and Valid to 

or Duration of restriction. If the restriction notice is Public, dates are not mandatory. 
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In the same panel, the value of the Duration of restriction field does not have to be 

numerical, the duration can also be described in words. 

 

The Actions table cannot be filled manually. The data will be inserted automatically when an 

object is merged, added as a child, or deleted. Example: if two functions are merged into one, 

the new function’s actions table will contain a new action: Function merged: 1.1.1 

Function_Name. 

 

The inactive buttons on the form are: 

• All except Save and Cancel if the series has not been saved. 

• All except Save, Mark, Print, Add Dossier and Cancel if the archival project has 

been marked as approved. 

• Add series, always if this is a sub-series form. 

• Create relationship if no other object has been marked.  

• Merge if no object of the same type has been marked. 

• Add as child if no series/function has been marked. 

3.4 Uploading archival descriptions 

To upload metadata to the UAM, open the previously created project (on the archival creator 

general view, click on the project name), open the project menu and select Load data. 

Next, make a selection: 

• From individual computer file – select and upload a single file. 

 
Drawing 9. Series/function XML selection view 

 

or  

 

• From folder – upload an entire folder.  
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Drawing 10. Series/function XML folder selection view 

 
To import, all files in the folder and its subfolders must be in a valid format. If a file in an invalid 

format is found, the import will fail and no files will be uploaded to the UAM. The UAM will display 

an error message. 

If the data has been imported successfully, the import report is displayed and the Import 

window will display the data from the XML content. A list of imported data will also be 

displayed. 

 

 
Drawing 11. Imported series 

 

The imported series/functions can be opened (by clicking on the name) and edited. The 

metadata editing form will open (see section Describing the Archival Structure Metadata ). 

3.4.1 Creating an Archival Structure  

3.4.1.1 Creating an Archival Structure from XML 

Open the archival project. Open the project menu and click Load data > Download archival 

structure > Single file (arh). A browser window will open to select the file. 
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Drawing 14. *.arh file selection view 

 

The UAM will verify the input file and read the function and series metadata from it. If the 

input file is invalid, the UAM will display an error message. 

 

3.4.1.1 Creating an Archival Structure from Folders 

Open the archival project. Open the project menu and click Load data > Download archival 

structure > Folder  or Folder (with files). A browser window will open to select the root 

folder. 

The rules are the following: 

• The first folder in the root folder is always a series level. 

• The last/deepest level folder is always a dossier. 

• Any folder between is a sub-series level. 

Similar import options can be found on 

• function level (Add series from folder, Add series from folder (with files)) under right 

click. 

• series level (Add dossier from folder) under right click. 

The import works in a drag-and-drop style as well. 

 

3.4.2 Connecting Imported Series/Function Data to the Archival 
Project 

Imported data must be added to the project manually. The project archival structure must be 

unapproved. 

Select the series/function, then right-click and select Mark. 

• To select multiple series/functions, use Select all. You can also hold down Shift (to 

select a range of objects) or Ctrl (to select individual objects) while clicking on the 

required series/functions.  

To delete the series/function, select Delete. 
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Drawing12. Selecting a series in the import window. 

 

Once the series/function has been selected, go to the archival structure general view and find 

the place where the selected data will be moved. Then select Add as child. The objects will 

be moved to the project. 

 

 
Drawing 13. Archival structure general view 

 

3.4.3 Repeated Import of Series/Function Metadata 

If a series or function that already exists is uploaded to the UAM, the values of the fields 

Name, Scope and Content will be overwritten. 

3.5 Uploading Archival Material (Dossier/Record/File) Metadata to 
the UAM 

Once the archival creator and archival structure data have been approved by the public 

archive’s archivist, the data can be marked as approved in the UAM (in the project editing 

form), to make sure that the data is not accidentally edited during future activities. The 

approval is received from the public archive’s archivist outside the UAM, and applied by the 

agency’s archivist. Editing the dossier, record and file level metadata is forbidden while 

waiting for the approval to be applied. 
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To upload the archival material metadata to the UAM, open the project menu and select Load 

data. Then make a selection:  

• From individual computer file – select and upload a single file. 

 
Drawing 15. Dossier/record/file XML selection view 

 

or 

 

• From folder – upload an entire folder.  

 

 
Drawing 16. Dossier/record/file XML folder selection view  
 

To import, all files in the folder and its subfolders must be in a valid format. If a file in an invalid 

format is found, the import will fail and no files will be uploaded to the UAM. The UAM will display 

an error message. 
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The UAM will verify the input files and metadata, and read the technical metadata from the 

files. Files not in the archival format will be converted as necessary (see Converting imported 

files). 

 

3.5.1 Converting Imported Files 

File conversion is part of the data import process. If the imported data contains files that are 

not in the archival format and the converter is turned on (see File -> Settings), they are 

converted automatically. After the conversion, the name of the file will be the same, only the 

extension will be changed. If automatic conversion fails, the files must be converted by other 

means and then replaced in the UAM. Such files will have the Upload new computer file 

icon in the UAM: 

 
Drawing 16a. Computer file view 

 

 

After the file import, a report will open, containing (among other data) information about the 

conversion that took place during the import.  
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Drawing 17. Import report 

 

All conversions performed during the import are visible both in the original file and the 

resulting file’s Actions list. 

3.5.2 Connecting Imported Material Data to the Archival Project 

 

A relationship is created automatically between the imported data and the project, but only if 

the series/function had been imported before and their ERMS reference code is the same as 

the dossier. 

 

If the data has not been moved to the project automatically, this can be done manually (see 

section 8.1 Connecting Imported Series/Function Data to the Archival Project). 

 

3.5.3 Repeated Import of Archival Material Metadata 

 

If a dossier that already exists is uploaded to the UAM, the dossier’s Name field will be 

overwritten. 
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If a record/file that already exists is uploaded to the UAM, and the identically named 

record/file is found, the user is asked whether to update the data or add a new record/file. 

3.6 Describing the Archival Material Metadata 

3.6.1 Dossier metadata 

To describe the metadata of an existing dossier, open the archival structure general view and 

click on the dossier name. When adding a new dossier, select Add dossier in the series form. 

In both cases the metadata description form will open. 

 

 
Drawing 18. Dossier metadata 

 

To save the data, at least the mandatory fields (marked with an *) must be filled.  

 

If one or more records have been added as children to the dossier, the dates cannot be 

changed. 

 

The Access restrictions table contains the mandatory fields Restriction notice and Valid to 

or Duration of restriction. If the restriction notice is Public, dates are not mandatory. 

In the same panel, the value of the Duration of restriction field does not have to be 

numerical, the duration can also be described in words. 

 

Related material can be added to the related material table manually, but some data will also 

be inserted by the system: 

• The Related object value cannot be selected manually.  

• The system will insert data if a relationship is created between two objects (the 

Create relationship button). The column Related object will be populated with the 

name of the related object. 
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The Actions table cannot be filled manually. The data will be inserted automatically when an 

object is merged, added as a child, or deleted. Example: if two dossiers are merged into one, 

the new dossier’s actions table will contain a new action: Dossier merged: 1.1.1 Some 

Dossier. 

 

The inactive buttons on the form are: 

• All except Save and Mark if the function has not been saved. 

• All except Save, Mark, Print and Cancel if the archival project has not been marked 

as approved. 

• Create relationship if no other object has been marked.  

• Merge if no object of the same type has been marked. 

• Add as child if no series/function has been marked. 

3.6.2 Record level description 

To describe the record metadata, open the archival structure general view and click on the 

record name. The metadata description form will open. 

The record level cannot be created manually. Record data must be imported into the system. 

 

 

 
Drawing 19. Record metadata 

 

 

The Access restrictions table contains the mandatory fields Restriction notice and Valid to 

or Duration of restriction. If the restriction notice is Public, dates are not mandatory. 

In the same panel, the value of the Duration of restriction field does not have to be 

numerical, the duration can also be described in words. 

 

The Annexes table is used to mark files that are appendices to this record. The dropdown 

menu displays all files related to this record. 
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Related material can be added to the related material table manually, but some data will also 

be inserted by the system: 

• The Related object value cannot be selected manually.  

• The system will insert data if a relationship is created between two objects (the 

Create relationship button). The column Related object will be populated with the 

name of the related object. 

 

 

The Actions table cannot be filled manually. The data will be inserted automatically when an 

object is merged, added as a child, or deleted. Example: if the record has been moved to a 

different dossier, the record’s actions table will contain a new action: Previous location: 

Previous dossier name. 

 

The inactive buttons on the form are: 

• All except Save, Print and Cancel if the archival project has not been marked as 

approved. 

• Create relationship if the project has been approved and no other object has been 

marked.  

 

3.6.3 File Metadata 

To describe file metadata, open the archival structure general view and click on the file name. 

The metadata description form will open. 

 

The file level cannot be created manually. File data must be imported into the system. The 

UAM will read the file metadata, and it cannot be edited. 
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Drawing 20. File metadata 

 

 

Descriptions of some data: 

• In archival format – determines whether or not the import/processing result file is 

in the archival format. 

• Original – determines whether this is the original imported file or a processed file. 

• Final – determines whether or not the file has been successfully processed in the 

previous step. Final = Yes is for files that have not been touched (conversion, 

decapsulation). 

• Copy – determines whether this is the original file or a dissemination file. 

3.7 Validating the Archival Project 

To validate the output parameters for the metadata of the archival structure and records, open 

the project menu and click Validate. The system will execute the validation procedure (check 

that the data is correct) and will display the errors encountered in the archival project in the 

validation window (bottom left). 
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Drawing 21. Validation results 

 

Click on the error in the validation window to open the form where the error was encountered 

and repair it. 

 

Typical validation errors and their descriptions: 

• “Element name” must be filled. Mandatory fields (marked with an *) are not filled. 

• Series cannot have other direct subordinates than sub-series and dossiers. The object 

cannot have two objects of different types as sub-objects. 

• Fond must contain at least one dossier. Each fond/series must have at least one 

dossier. 

• There are more than one items with the same title at this level. Objects on the same 

level within the same description unit must be unique. 

• There are two archival creators with same official name. The official names for 

subcreators under a common A language can appear only once at one level. 

• A language can appear only once at one level. The language selection list can only 

include the same language once. 

• One keyword can appear only once at one level. Keywords must be unique within one 

description unit. 

• There are more than one dossiers in the description unit with the same title and same 

dates. The dossier view’s title and dates must be unique. 

 

The validation process identifies all XLSX, DOCX and ODF files with enabled track-and-

change functionality. These files can be manually downloaded from UAM, the track-and-

change functionality disabled and uploaded again to UAM if required. 

 

Validation errors must be resolved before the archival project is transmitted. If some 

validation error cannot be resolved, the archives must be informed in order to accept 

the project with validation errors.  

If there are no validation errors, the message No errors found in the project! will be 

displayed. 

3.8 Transmitting the Archival Structure to the Public Archive for 
Approval  

The UAM can be used to save the archival creator and archival structure data to an XML file 

and send it via email or X-Road to the public archive’s archivist for approval. To transmit the 

data, open the Project menu and select Send. A selection window will open: 
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Drawing 22. Transmitting the archival structure  

3.8.1 Transmitting Data via X-Road 

To send the data via the X-Road, all the DHX/X-Road settings must be defined. Select 

DHX/X-Road as the option to transmit the archival structure. 

The DEC can be used to send: 

• Archival structure 

• Archival structure and record containers 

• Record containers 

Select the appropriate option and click Send. 

 

After the records have been transmitted, the transmission report will be displayed. This shows 

how many containers were created, and whether there were any errors during the 

transmission. 

 
Drawing 23. Transmission report 

 

3.8.2 Saving Data to Media 

To save the data to the computer’s hard drive/memory stick/etc., select Save as file as the 

transfer media type. The following can be saved: 

• Archival structure 

• Archival structure and record containers 

• E-ARK formats 

 

In either case, you will need to specify the Location on disk – the place where the files will 

be saved. 

To save the archival structure and record containers, select the Max media capacity. If the 

container size is larger than the selected maximum capacity, a system of folders titled disk 1, 

disk 2 etc. will be created on the media. Each “disk” size is smaller than the selected media 

capacity. 
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Drawing 24. Saving data to media as files 

3.9 Additional Menu Options  

3.9.1 Viewing the Record Container   

Record containers can be opened with a double-click on UAD files or via the File menu in the 

application. 

Open the File menu and select View record container. In the window that opens, select the 

XML file for the record container whose contents you would like to view. 

 
Drawing 25. Selecting the record container 

 

After the record container is selected, the container’s contents will be displayed, including the 

record and links to files. 
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Drawing 26. Record metadata 

 

If the ERMS reference codes are the same for the record and the project, then the Project 

field will contain a link the archival project. Click the project name to open the project form. 

 

Click the file name to open the file form. 
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Drawing 27. File metadata 

 

Click Open file to see the file contents. 

3.9.2 System Settings 

To use UAM, you must first configure the system settings. The initial configuration is 

performed during the system’s installation and the first execution of the UAM. If settings 

need to be changed or augmented later, this can be done by selecting the File menu, then 

Settings. The input fields available in the Settings window are described in detail in the UAM 

Installation Guide. 
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Drawing 28. System settings 

 

3.9.3 Comparing Archival Structures 

Select a project. Next, open the Project menu and select Compare archival structure.  

There are two options for comparison: 

• Compare to another project in the UAM 

 
Drawing 29. Project selection 

 

• Compare to an archival structure XML 
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Drawing 30. Selecting an XML for comparison 

 

After the comparison method and the project/XML file are selected, a form will be displayed, 

containing the project’s structural tree (down to the series): 

• The added description hierarchy is highlighted in green 

• The removed description hierarchi is highlighted in red 

• Parts with a different name but the same ID are highlighted in blue. 

 

 
Drawing 31. Comparison of archival structures 
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Select Reversed comparison to flip the comparison around. Originally the UAM project was 

compared to the XML file, now the XML file will be compared to the UAM project. 

If the project data in the UAM has changed in the meantime, click Refresh to see the most 

recent data. 

3.9.4 Search 

The UAM can be used to search for units within the same project. Select the project, then 

open the Project menu and select Search. There are two search methods: 

 

• Full text search (simple search) across all UAM text fields (including reference codes) 

 
Drawing 32. Simple search 

 

• Advanced search (by title/file name, reference code, dates, hierarchy level)  

 
Drawing 33. Advanced search 

 

The search covers the currently open project. File contents are not searched. 

 

If the search is successful, the search results are displayed in the same window: 

 
Drawing 34. Search results 
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Doubleclick on the title or right-click and select Open to go to the description unit. 

 

If the search is unsuccessful, the message No results were found is displayed. 

3.9.5 Undoing Actions 

The UAM supports: 

• Cancelling the addition of a new unit, using the Cancel button on each form. 

• Cancelling the changes to a unit’s data, using the Cancel button on each form. 

• Undo non-form actions such as merging units, moving and deleting them. 

 

When performing non-form actions, the Actions menu will contain an Undo option along 

with a description of the action (and a timestamp). Selecting this menu option will restore the 

system status to what it was before the action. For example, if the menu option refers to the 

addition of a new unit, the system will be restored to the condition before the unit was added. 

If the menu option refers to the merger of two units, the system will be restored to the 

condition when the units were still separate. 

• If the Undo submenu’s topmost option was selected, only one action is undone. 

• If one of the Undo submenu’s lower options was selected, all actions above it in the menu are 

undone. 

• Each undone action will create an option in the Actions menu’s Redo submenu. 

 

 
Drawing 35. Undoing actions 

 

 

Drawing 36. Redoing actions 

• To redo the last undone action, open the Actions menu, then the Redo submenu, and select 

the topmost menu option. For example, if the menu option refers to the creation of a new unit 

that was cancelled via the Undo menu, the unit will be created again. 

• To redo a series of undone actions, open the Actions menu, then the Redo submenu, and 

select a lower menu option. All the actions above it will also be redone. 

• Each redone action will create an option in the Actions menu’s Undo submenu, just as 

happened when the actions were performed originally. 

• If a lower menu option is selected from the Redo submenu, all the redone actions are 

added to the Undo submenu in reverse order. 
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Undoing and redoing is only possible for non-form actions. For example, if a relationship is created 

between units and a field in one of those units is edited afterwards, then undoing the relationship 

creation does not restore the edited field to its old value. 

Please note: Undo and redo options are cleared when the archival material’s metadata is uploaded to 

an archival project. 

3.9.6 Printing Data 

The UAM supports printing out the contents of every form, via the Print button. The 

Printouts menu supports the following printouts for the currently selected project: 

• Archival structure printout 

• Archival list printout 

• Integrity report printout 

• Error list printout. 

 

3.9.7 Backing up and restoring metadata and files 

Select Backup data under the Help menu in order to back up the metadata and files. 

 
Drawing 37. Backup data 

 

UAM creates a ZIP file containing the backup of the database and files folder. 

 

Select Restore from backup in order to restore the database and the files folder. 

 
Drawing 38. Restore from backup 
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UAM opens a window where you can select the backup (ZIP) file and start the restoration process. 

 

Drawing 39. Restore data from backup 

3.9.8 Error report 

Select Help -> Create error report in order to collect all relevant files (RahvusarhiivLog.txt, 

UAM.exe.config) that are necessary for the identification of the cause of the encountered 

error. All files will be zipped into one ZIP container. 

 

 

Drawing 40. Create error report 
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3.9.9 File analysis 

Select Project -> Analyse files in order to analyse files in your project.  

 

 

Drawing 41. Analyse files 

All files will be included in the file analysis (incl. zipped and digitally signed containers). The 

result is presented in the validation window and as a PDF file. The report contains 

information about the total number and size of files in the project, plus information about their 

formats. 

NB! The file added to the description of the structure of the archival creator is excluded from 

the file analysis. 

3.9.10 File uniqueness check 

UAM allows to identify duplicating files in the project if selecting Project -> Check for 

duplicate files.  

 

Drawing 42. Check for duplicate files 

All files will be included in the check (except the duplicates in the same container (e.g. ZIP, 

DDOC, …)). The check is based on file hash sums. 

The result is presented in the validation window. 

3.9.11 Project re-import  

Right-click on the name of the archival creator opens a choice "Import project". 
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Drawing 43. Project re-import in UAM 

Re-import is based on the ARH and UAD files – it creates a new project based on the content 

and metadata encapsulated in these files. 

No content conversions, unpacking or other processing are done during the re-import of the 

project. The content and metadata will be imported into UAM exactly as they are in the ARH 

and UAD files. 

 


